Skip to main content

Contoh Konfigurasi Switch dan Router buat VLAN

Dibawah ini adalah contoh konfigurasi sederhana untuk membuat sebuahjaringan yang terdiri dari 4 VLAN dan bisa berkomunikasi antar jaringan melalui bantuan router.

Konfigurasi Switch

Konfigurasi switch disesuaikan dengan kebutuhan jaringan yang ada, yaitu membuat 4 buah VLAN. VLAN-VLAN lainnya bisa ditambahkan sesuai kebutuhan jaringan. Konfigurasi yang dibuat adalah seperti berikut :

  • Membuat VLAN.
    Switch#vlan database
    Switch(vlan)#vlan 10 name VLAN1
    Switch(vlan)#vlan 20 name VLAN2
    Switch(vlan)#vlan 30 name VLAN3
    Switch(vlan)#vlan 40 name VLAN4
    Switch(vlan)#exit

  • Menentukan port sebagai trunk dan setting enkapsulasinya.
    Switch#config terminal
    Switch(config)#interface fastethernet 0/12
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#switchport trunk encapsulation dot1q
    Switch(config-if)#exit

  • Menentukan port untuk tiap VLAN dan port access-nya.
    Switch(config)#interface fastethernet 0/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 10

  • Memverifikasi pengaturan switch.
    Switch#show vlan ==> Lihat semua VLAN yang ada.
    Switch#show vlan [number] ==> Lihat VLAN berdasarkan ID.
    Switch#show running-config ==> Lihat hasil konfigurasi.


Konfigurasi Router

Salah satu fungsi dari router adalah meneruskan paket-paket data dari satu jaringan ke jaringan lain. Agar setiap VLAN bisa melakukan komunikasi dengan VLAN lainnya dibutuhkan sebuah router untuk menghubungkannya. Konfigurasi yang dilakukan pada router adalah sebagai berikut :

  • Buat Sub-interface sebanyak VLAN yg telah dibuat.

  • Setting setiap gateway di setiap sub-interface.

  • Setting enkapsulasi sesuai dengan enkapsulasi pada switch.
    Router#configure terminal
    Router(config)#interface fastethernet 0/0
    Router(config-if)#no shutdown
    Router(config)#interface fastethernet 0/0.10
    Router(config-subif)#encapsulation dot1q 10
    Router(config-subif)#ip address 192.168.1.1 255.255.255.0
    Router(config)#interface fastethernet 0/0.20
    Router(config-subif)#encapsulation dot1q 20
    Router(config-subif)#ip address 192.168.2.1 255.255.255.0
    Router(config)#interface fastethernet 0/0.30
    Router(config-subif)#encapsulation dot1q 30
    Router(config-subif)#ip address 192.168.3.1 255.255.255.0
    Router(config)#interface fastethernet 0/0.40
    Router(config-subif)#encapsulation dot1q 40
    Router(config)#ip address 192.168.4.1 255.255.255.0


Protokol dot1Q digunakan untuk menghubungkan VLAN-VLAN yang ada. Penggunaan protokol tersebut karena perangkat switch berasal dari 2 vendor yang berbeda, yaitu Cisco dan Planet. Dot1Q adalah standard industri yang memungkinkan 2 buah switch yang berbeda vendor bisa melakukan trunking untuk menghubungkan VLAN.

Comments

  1. kunjungi blog saya ya :)
    http://jaketkuning.unsri.ac.id/ZizaSurest/blog/1088/

    ReplyDelete
  2. thanks 4 sharing,
    Mungkin lebih bagus kalo ada gambarnya.. :)

    ReplyDelete
  3. Great post, and great website. Thanks for the information! 192.168 49.1

    ReplyDelete

Post a Comment

Popular posts from this blog

Keanggotaan, Keuntungan, dan Konfigurasi Umum VLAN

Keanggotaan dalam suatu  VLAN dapat dikelompokkan berdasarkan port yang digunakan, MAC address, atau tipe protokol yang digunakan. Berdasarkan Port Keanggotaan pada suatu VLAN dapat di dasarkan pada port yang digunakan oleh VLAN tersebut. Sebagai contoh, pada bridge/switch dengan 4 port, port 1, 2,  dan 4 merupakan VLAN 1 sedang port 3 dimiliki oleh VLAN 2, lihat Tabel 2.1 berikut ini. Tabel 2.1 VLAN berdasarkan port Port 1 2 3 4 VLAN ID 2 2 1 2 Kelemahannya adalah pengguna tidak bisa untuk berpindah-pindah. Apabila harus berpindah maka administrator  jaringan harus mengkonfigurasikan ulang. Berdasarkan MAC Address Keanggotaan suatu VLAN didasarkan pada MAC address dari setiap  komputer yang dimiliki oleh pengguna. Switch akan mencatat semua MAC address yang dimiliki oleh setiap Virtual LAN. Kelebihannya apabila pengguna berpindah-pindah maka dia akan tetap terkonfigurasi sebagai anggota dari VLAN tersebut. Kekurangannya adalah setiap mesin harus dikonfigurasi secara m

Jenis Router, Keutungan, dan Kerugian Router

Ada tiga  jenis router yang biasa digunakan dalam  jaringan komputer , yaitu: Router PC Router PC adalah komputer dengan sistem operasi yang memiliki fasilitas untuk membagi  dan men-sharing IP Address. Perangkat jaringan (PC) yang terhubung ke komputer tersebut akan dapat menikmati IP Address atau koneksi internet yang disebarkan oleh sistem operasi tersebut. Contoh sistem operasi yang dapat digunakan adalah semua sistem operasi berbasis client-server, seperti Windows NT, Windows NT 4.0, Windows 2000 server, Windows 2003 Server, MikroTik (Berbasis Linux), dan lain-lain. Router Aplikasi Router aplikasi adalah aplikasi yang dapat di-install pada sistem operasi sehingga sistem operasi tersebut akan memiliki kemampuan seperti router. Contoh aplikasi ini adalah Winroute, WinGate, SpyGate, dan WinProxy. Router Hardware Router hardware adalah hardware yang memiliki kemampuan seperti router sehingga dari hardware tersebut dapat memancarkan atau membagi IP Address dan men-sharing IP

Keuntungan dan Kerugian VoIP

Keuntungan VoIP Bertelepon menggunakan VoIP memberikan banyak keuntungan. Yang paling terlihat adalah dari segi biaya yang jelas lebih murah dari tarif telepon tradisional, karena jaringan IP bersifat global sehingga untuk hubungan internasional dapat ditekan hingga 70%. Selain itu, biaya maintenance dapat ditekan karena jaringan suara dan data terpisah, sehingga IP phone dapat ditambah, dipindah, dan diubah. Hal ini karena VoIP dapat dipasang disembarang ethernet dan IP address, tidak seperti telepon tradisional yang harus mempunyai port tersendiri di sentral atau PBX. Kelemahan VoIP Begitu banyaknya keuntungan yang ditawarkan oleh VoIP, tetapi masih ada kelemahan-kelemahan yang ditemukan seperti sulitnya mengirimkan fax, perlu jalur internet yang cepat ( biasanya backbone diharuskan menggunakan Fiber Optic ), dan susah untuk menentukan emergency call. Kelemahan jaringan yang menjadi musuh utama dari VoIP antara lain : -      Delay Jaringan yang berbasis atau dengan backbone